Horn Issues

Q&A: Technical Support
5 posts Page 1 of 1
PurpleRain
6th Planet Addict
Posts: 179
Joined: Thu Feb 01, 2007 10:09 am
Location: Hamilton
by PurpleRain » Fri Mar 19, 2010 4:50 pm
A few months ago I was getting out of my car, pushed the lock on the key fob twice (as usual) and the horn honked and wouldn't stop. Constant honking. I tried hitting unlock, and the panic button and everything to make it stop and it wouldn't. Finally, I had to pull the fuse after everyone in the parking lot was looking at me.

The other day, I decided that it's been a few months without a horn, so I would try putting the fuse back in to see if it still did the same thing. The second the fuse contacts touched the contacts under the hood, the horn came on again, constant, loud, screaming horn.

Has anyone else ever had this problem, or heard of this problem?

 

andrew88
Our Fearless Leader
Posts: 371
Joined: Thu Jul 31, 2008 9:54 pm
Location: Innisfil ,Ont
 
by andrew88 » Fri Mar 19, 2010 6:36 pm
I have not had it happen on a Saturn yet but have seen it a few different things happen..

Saturn supply 12v constantly and use ground for switch so if the mount were to break and the horn were to ground against the car it would go off..
Some models have relays for the horns but not all? So could be a relay stuck open, under the hood in the fusebox.
Connector could be all corroded from Mr Green and grounded the the switch with the ground making it go.
Switch wire rubbed through and grounded.

There are a few things to try anyways.. hope it helps!

 

01saturnsc1
6th Planet Addict
Posts: 169
Joined: Mon Dec 11, 2006 1:04 pm
Location: Oakland,Ont
 
by 01saturnsc1 » Fri Mar 19, 2010 9:39 pm
My 01 has a simular issue and was the relay

 

Slayer
O6P Staff
Posts: 1568
Joined: Sat Oct 14, 2006 5:33 pm
Location: Hamilton
 
by Slayer » Sat Mar 20, 2010 2:44 pm
when i bought minem, the owner said she had the same issue so she pulled the fuse, i swapped out to a new horn, and it works fine. do you want to swap my known working horn in and see if this corrects the problem? if it works normal you'll know its the horn..

is there not a built in relay on the horns that go bad?

 

98-sc2-301
Verified Newbie
Posts: 3
Joined: Wed Apr 21, 2010 11:26 am
Location: Angus Ontario
 
by 98-sc2-301 » Thu Apr 22, 2010 2:11 am
i had the exact same problem but with air horns .. in a tims parking lot -_-
5 posts Page 1 of 1
kuchnie na wymiar radomsko

Who is online

Users browsing this forum: No registered users and 3 guests